
Дано арифметическое выражение 5xyА18 + 18x7y. 
Определите, сколько различных значений может принимать выражение при всех возможных x и y.

s = set()
tmp = ''
for y in range(9,18):
    for x in range(0,y):
        #print(y,x, f'5*18**3+{x}*18**2+{y}*18+10 + 1*{y}**3+8*{y}**2+{x}*{y}+7')
        s.add(5*18**3+x*18**2+y*18+10 + 1*y**3+8*y**2+x*y+7)
print(tmp,len(s))